Skip to main content

新内容编辑器(Beta)

Note

本文档采用 AI 辅助机器翻译。译文仅供参考,不保证准确性;此内容的英文版为官方权威版本。

如果您的机构正在参与 Blackboard 文档新内容编辑器的抢先体验项目,您可以在创建文档或向现有文档添加内容块时使用测试版内容编辑器。新编辑器的工作方式与经典编辑器类似:你可以添加和格式化文本,附加文件,并插入媒体、链接和表格。

测试版内容编辑器尚未支持经典内容编辑器的所有功能。有关功能对比,请参阅内容编辑器对比表。

访问测试版内容编辑器

创建新文档:

  1. 在课程内容页面,选择 加号 创建新内容,并选择 创建 。

  2. 在打开的面板中,选择 文档 。

  3. 选择 内容,并选择新编辑器(测试版)。

    在选择要添加的块的内容类型时,内容菜单会展开,显示“新编辑器 BETA”(用方框高亮)和“经典编辑器”选项。

向现有文档添加内容块:

  1. 在课程内容页面,从文档更多选项(...)中选择编辑菜单。

  2. 选择加号以添加内容块。

  3. 选择 内容,并选择新编辑器(测试版)。

将现有内容转换为测试版内容编辑器。

你可以将使用经典内容编辑器创建的内容转入测试版内容编辑器。

  1. 打开一个包含使用经典内容编辑器创建的内容块的文档。

  2. 选择编辑器下方的尝试新编辑器链接。

    经典内容编辑器,输入“This is the content with the classic editor”(这是使用经典编辑器创建的内容)。在编辑器下方的右侧,“尝试新编辑器”链接会用一个框高亮显示。

内容将从经典内容编辑器转换为测试版内容编辑器。如果您的内容包含测试版内容编辑器不支持的功能,这些功能将在转换过程中被移除。如果您保存更改,就无法撤销转换的弹窗将显示。

仔细审查你的内容,确保所有内容完整,并且你想保留已转换的内容。如果你丢失了内容且对结果不满意,可以使用文档层级的撤销按钮(而非内容编辑器中的撤销按钮)。

名为“新编辑”的文件出现在“人文学科导论”课程中。显示添加内容块、自动生成布局、撤消、重做、取消和保存按钮。“撤销”按钮会高亮显示一个框。

首次使用用户体验

当你第一次打开测试版内容编辑器时,会弹出一个窗口,突出显示编辑器中的一些更改,并说明如何提交反馈。

弹出窗口标题为“Blackboard 的新编辑器”,包含“最新动态”、“几点需要注意”和“有反馈或遇到问题?”等栏目。

测试版内容编辑器的新内容

重新设计的工具栏和菜单结构

  • 编辑、格式和插入菜单为你提供了一个基于文本的有序编辑器选项视图。这使你在移动设备上更容易找到所需的选项。

    • 编辑:撤消、重做、清除格式

    • 格式:文本样式、字体特征、段落样式、代码和表格

    • 插入:可在内容编辑器中插入的所有内容

  • 基于 图标的工具栏 显示了最常用的编辑、格式化和插入选项。

  • Toolbar actions that are turned off use higher contrast, so you can tell at a glance which options are unavailable.

  • 一个内联工具栏显示与你选择的选项相关的选项。例如,如果你选择某个表格,你可以快速访问表格选项。内联工具栏显示表格、文件上传、图像、音频和视频。

键盘导航

  • 可以使用键盘访问菜单栏、工具栏和内联工具栏。

    区域

    Windows operating system

    Mac OS

    菜单栏

    Alt + F10

    Fn + Opt + F10

    工具栏

    Alt + F11

    Fn + Opt + F11

    内联工具栏

    Alt + F9

    Fn + Opt + F9

  • A skip navigation link appears as you move through the Content Editor with a keyboard, giving you quick access to the editor’s keyboard navigation instructions and shortcuts.

  • 工具栏上的快捷键打开一个集中的参考,涵盖菜单栏、工具栏、内联工具栏和编辑器之间的导航,以及基于键盘的图像调整。

  • 编辑和插入菜单会在常用操作旁边显示键盘快捷键。

增强表支持

  • 创建具有简化工作流程的表格,结合行和列选择以及标题选项。

  • 选择 Tab 键即可快速在表格单元格间移动。

  • 选择一个或多个单元格以应用单元格级格式设置。

  • 表格编辑完全支持撤销和重做。

  • 将代码片段和代码块直接插入表格单元格中。

  • 合并和拆分单元格,以构建更复杂的布局,并更好地组织表格内容。

  • 调整栏的大小以适应你的内容并提高可读性。

  • 宽于内容区域的表格现在会显示水平滚动条。

增强列表支持

  • 嵌套列表使用缩进和不同深度的项目符号样式,使列表层级更易于理解。

  • 在编辑内容时,有序列表会保持其编号顺序正确。

  • 在同一列表中将有序和无序列表项合并。在每个级别中,选择所需的项目符号或数字样式。

  • 软回车(Windows 上的 Shift + Enter,Mac 上的 Shift + Return)保留已有的列表项,而硬回车则开始新的列表项。

  • 嵌套层级没有限制,深度嵌套列表将显示水平滚动条。

增强链接支持

  • 选择 Ctrl + K(Windows)或 Cmd + K(Mac)以打开“链接”对话框。

  • 选择文本后,将 URL 粘贴到内容编辑器中,以将所选文本转换为可点击的链接。

  • 输入或粘贴一个独立的 URL,即可自动将其转换为可点击的链接。

    注意

    最佳实践:对于符合 WCAG 标准的内容,请提供描述性文字链接,而不是原始 URL。使用“链接”对话框(选择“链接”图标,或按 Ctrl+K/Cmd+K)添加描述性的链接文本。

改进的格式选项

  • 除了完整的代码块外,使用内联代码片段可以让编写代码时更灵活。

  • 将图像缩放至最小 100 像素。

  • 直接在内容编辑器中调整图像大小。

  • 使用工具栏或 格式 菜单中的 增加缩进 选项来对段落进行缩进。你可以缩进段落的第一行,也可以根据光标所在的位置,或整段进行缩进。

Files and images

  • Set file properties as you upload an image. File properties open when you upload an image, so you can add alternative text and choose display options before the image is inserted.

    blackboard-instructor-content-editor-image-properties-alt-text.png
  • Use files from the Content Collection. Browse and select files from the Content Collection without leaving the editor

Math authoring

  • The Content Editor renders LaTeX and MathJax, including LaTeX \begin{...}...\end{...} environments.

提交关于测试版内容编辑器的反馈

你可以直接向 Blackboard 发送编辑反馈。

  1. 在插入菜单旁,选择提交反馈按钮以打开反馈表单。表格会自动收集你提交申请时的具体位置信息。

    在测试版内容编辑器中,当未输入文本时,将显示插入菜单右侧的“提交反馈”按钮,并用一个框高亮显示。
  2. 请输入你的反馈。

    新编辑器的反馈表单在屏幕右侧打开,测试版内容编辑器显示在屏幕左侧。反馈表单里有个字段,问“你使用新编辑器的体验如何?”它按预期运行了吗?还是遇到了什么问题?“并配有占位文字”请输入你的答案。还有一个预填的“Blackboard 页面 URL”字段。底部有一个提交反馈按钮。
  3. 选择表格中的提交反馈按钮。