Troubleshoot the Microsoft Power Automate Integration

You can use the troubleshooting page to address and resolve issues that may occur in Microsoft Power Automate sample flows used for Faculty Workload contract management in Anthology Student.

ClosedFlow Failures

Symptoms

After you import and configure Microsoft Power Automate sample flows to automate the approval and eSign process in Anthology Student for Faculty Workload contract management, the flow fails to execute and might display an error message explaining the reason for the failure.

Possible Causes

This issue may occur due to the following reasons:

  • Microsoft Power Automate sample flows have not been configured correctly

  • One or more of the required fields are missing data

Action to Take to Resolve

To resolve this issue:

Type of Issue Scenario What it means Resolution

Generic

Failure of the flow

Flow failed.

Check the issue in the flow. For more information, refer to Identify the Error via Flow History below the table.

Failure of the flow due to an authentication error

Flow failed because of an authentication error. An error message, such as Unauthorized, or an error code of 401 or 403 is displayed.

Update the connection. For more information, refer to https://docs.microsoft.com/en-us/power-automate/fix-flow-failures#authentication-failures.

Failure of the flow

Flow failed with an error code 500 or 502. The failure is temporary or transient.

Select Resubmit to try the flow run again.

Flow execution is slow

Flow executed slowly.

Select the link to fix the issue. For more information, refer to Troubleshooting Slow Running Flows.

 

Failure of the flow due to the Action configuration

The flow failed because of the setting in the Action of the flow did not function as expected. An error message is displayed as Bad request or Not found, or an error code of 400 or 404.

Error details specify how to correct the failure. Select the Edit button and correct the issue in the flow. Save and resubmit the flow.

Request limits and allocations crossed scenario

Scenario where the number of API requests per day for the license has exceeded, which in turn slows the flow execution.

Check the limit and allocations. For more information, refer to https://docs.microsoft.com/en-us/power-platform/admin/api-request-limits-allocations.

Unable to invoke the Power Automate flow

Incorrect value specified for workflow URL specified in Settings.

Update the workflow URL.

Failure of the invite/response flow due invalid Admin email ID in the configuration step

Flow failed because of the wrong Admin email ID with the following error message:

OpenApiOperationParameterTypeConversionFailed. The 'inputs.parameters' of workflow operation 'Send_Failure_Message_to_administrator' of type 'OpenApiConnection' is not valid. Error details: Input parameter 'emailMessage/To' is required to be of type 'String/email'. The runtime value '"<AdminEmailId>"' to be converted doesn't have the expected format 'string/email'.

Update the Admin email ID in the configuration section of the flow. For more information, refer to Configure Flows Using Microsoft Power Automate.

Failure of the invite/response flow due missing Admin email ID in the configuration step

Flow field because of an empty Admin email ID with the following error message in the body:

BadRequest.

Parameter 'To' cannot be null or empty.

Approver workflow

Approver did not receive email

The appprover did not receive mail.

Check whether the approver mail ID is specified in the configuration step of the sample approval flows. If missed, update the approver mail ID in the flow.

Check for the request limit. For more information, refer to https://docs.microsoft.com/en-us/power-platform/admin/api-request-limits-allocations.

Failure of the flow due to timeout of approval action

The flow failed because the approver did not respond within the timeout duration.

Check the settings of the approval action. You can set the desired timeout in ISO-8601 format. The default timeout of the approval action is 30 days.

Required field assignedTo is missing or empty

Approver mail ID is not configured in the flow.

Check the flow history or the error log provided in mail. Ensure that you have configured the approver mail ID in the Configuration block of the flow.

Required field assignedTo does not consist of valid users in the organization

Approver mail ID is out of domain.

The approval requester must be a single, valid user account within your organization

Requester mail ID (Designer mail ID) is not configured in Anthology Student.

Check the flow history or the error log provided in mail. Ensure you have configured requester mail ID in Staff page (Select the Settings tile > expand System > select Staff.).

Requester mail ID (Designer mail ID) is out of domain.

eSign SignNow workflow

Failure of invite to SignNow with an error

Failure of invite to SignNow flow mail received.

Check the issue in the flow. For more information, refer to Invite to SignNow Failure with an Error below the table.

Cannot send a field invite

Incorrect eSign tags in the template.

Check whether eSigns tags are correct.

For more information, refer to Background for SignNow eSignature and https://www.signnow.com/features/add-text-tags-to-the-document.

Signature field/tag is missing in the template and subsequently in the merged contract.

Signature field/tag is added in the template and subsequently in the merged contract.

Conversion issue in contract content.

Convert the content of the contract from base64 to binary format in the flow. For more information, refer to Convert Contract Content from base64 to Binary Format below the table.

Failure of the invite flow due to invalid_client

Flow failed because of wrong/Invalid SignNowAPIAuthToken or wrong/Invalid UserId/Password with the following validation: code":"BadRequest","message":"invalid_client'.

Update the SignNowAPIAuthToken/userId and Password with valid information in the Secure configuration action. For more information, refer to Configure SignNow Flows Using Microsoft Power Automate.

Failure of the invite/response flow when the base URL is missing in the SignNow flows.

Flow failed because of missing base URL with the following validation:
code":"BadRequest","message":"The provided 'Http' action URI '*sanitized*' is not valid. The URI must be a well-formed absolute URI not referencing local host or UNC path.

Update the base URL to https://api.signnow.com/. For more information, refer to Configure SignNow Flows Using Microsoft Power Automate.

Failure of the invite/response flow when the base URL is invalid

Flow failed because of invalid base URL with the following validation: code":"UnresolvableHostName","status":"Failed","error":{"code":"UnresolvableHostName","message":"Http request failed with status code 'NameResolutionFailure' and status message: 'The remote name could not be resolved: 'https://InvalidBaseUrl''

Status of the contract is not updated even after the faculty has e-Signed (Accepted / Rejected)

Status of the contract is not updated in Faculty Contract Assignment & eSignature page (Select the Processes tile > locate Faculty Workload > select Faculty Contract Assignment & eSignature.) in Anthology Student even after the faculty has accepted or rejected the contract.

Update the callback URL of the Response flow in the invite flow. For more information, refer to Configure Flows Using Microsoft Power Automate.

eSign Adobe Sign workflow

Failure of the invite/response flow due to an invalid/blank Integration Key in the Adobe Sign flows

Flow failed because of an authentication error. An error message is displayed as Unauthorized or an error code of 401 or 403.

Update the Integration Key in the Adobe Sign configuration. For more information, refer to Configure Adobe Sign Flows Using Microsoft Power Automate.

Failure of the invite/response flow when the base URL is missing in the Adobe Sign flows

Flow failed because of missing Adobe base URL with the following validation: code":"BadRequest","message":"The provided 'Http' action URI '*sanitized*' is not valid. The URI must be a well-formed absolute URI not referencing the local host or UNC path."

Update the base URL to https://api.in1.adobesign.com/. For more information, refer to Configure Adobe Sign Flows Using Microsoft Power Automate.

Failure of the invite/response flow when the base URL is invalid in the Adobe Sign flows

Flow failed because of invalid Adobe base URL with the following validation: code":"UnresolvableHostName","status":"Failed","error":{"code":"UnresolvableHostName","message":"Http request failed with status code 'NameResolutionFailure' and status message: 'The remote name could not be resolved: 'api.in1.adobeapi''

The Adobe eSignature response flow is not triggering after the faculty member Accepts/Rejects the Contract

There can be more than one eSignature response flow configured for the same account. Adobe supports only one response flow (that is, Webhook) to be configured for one account.

Identify the unused eSignature response flows in Power Automate and switch it off.

Identify the Error via Flow History

  1. Select Solution where the flow is deployed/available.

  2. Select the failed flow or select the link in the flow failure notification mail sent from the sample flow to directly go to the flow.

  3. In the 28-day run history section, select the date of the flow run that failed. Microsoft Power Automate displays the details of the flow with at least one step with a red exclamation icon.

    Example for 28-day run history

  4. Open the failed step and review the error message. Microsoft Power Automate displays details of the error and the solution to fix the error in the right pane.

    Solution Pane

Invite to SignNow Failure with an Error

Contracts are sent to faculty members for acceptance or rejection via SignNow APIs. In case of success or failure, the mail will be sent to the administrator along with the link to the sample flow.

Request Mail

  1. Select the link in the mail. Microsoft Power Automate displays the flow URL.

  2. Check the flow.

    Mail Notification of Invite Flow Failed

  3. Expand the failed action and resolve the issue.

    Expanded failed action.

Convert Contract Content from base64 to Binary Format

  1. Select the link in the mail. Microsoft Power Automate displays the flow URL.

  2. Check the flow.

  3. Expand the failed action and check the issue.

  4. Update the expression from triggerMultipartBody(0)[['$Content'] to base64ToBinary(triggerMultipartBody(0)['$Content']).

    Convert Expression

  5. Save the flow.