Users Unable to Join the Waitlist for Events on the Portal

Problem

When a portal user tried to register for an event that had reached its maximum capacity, the user was not waitlisted for the event and an error occurred even though the waitlist functionality was enabled for the event in Anthology Reach.

Cause

With the release of the Real-time Journey feature, Microsoft has enhanced the Event form to display a new field, Waitlist This Event (msevtmgt_waitlistthisevent) in place of the Show Waitlist (msevtmgt_showwaitlist) field that was previously available with the Outbound Marketing feature. The Show Waitlist field will no longer be displayed on the Event form and is always set to No.

The Event Details form shipped out-of-the-box(OOTB) has been updated in the Anthology Reach 2024.4.0 release. Customized Event Details page must be manually updated using the steps provided in the Solution section below.

Solution

Update the customized Event Details page and the EventDetails.js file on the portal as follows:

  1. On the Sitefinity portal, edit the customized Event Details page as follows:

    1. Drag and drop a Picklist field, and click Edit.

    2. In the Picklist dialog, click the Attribute field and select Waitlist this event and click Save.

  2. Open the EventDetails.js file (available under ~/ResourcePackages/CampusNexusEngage/assets/dist/Scripts/Forms) in an editor and replace the "let showWaitlist = tpc.find("msevtmgt_showwaitlist").get_value();" line with the following code snippet, and save the file:

    let oldWaitlistFieldValue = tpc.find("msevtmgt_showwaitlist").get_value();

    let newWaitlistFieldValue = tpc.find("msevtmgt_waitlistthisevent").get_value().toString();

    let showWaitlist = oldWaitlistFieldValue == true || newWaitlistFieldValue == "100000002" ? true : false;